Autor Tópico: CNC Shield V4 com Arduino Nano  (Lida 53 vezes)

Description:

0 Membros e 1 Visitante estão vendo este tópico.

Offline Papa-Léguas69

  • Novato
  • *
  • Posts: 3
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: Cravinhos - SP
  • Nome:: Rene
  • Profissão: Analista de sistemas
CNC Shield V4 com Arduino Nano
« Online: 25 de Setembro de 2018, 18:38 »
Boa noite pessoal,


Meu nome é René, mas pode me chamar de Papa-Léguas ou simplesmente Papo, como me chamam em casa. Sou novo nesta área de CNC's, estou montando uma baseado no projeto do Marlon Nardi, a 2.1 e já estou planejando a construção da 3.0. Sou analista de sistemas por formação e comecei no mundo Arduino a pouco tempo.


Bem, estou com um problema meio cabuloso de resolver: Eu comprei um kit Arduino para CNC composto por 1 Arduino Nano, 3 drivers de motor A4988 e uma CNC Shield V4 (aquela com apenas 3 slots para driver de motor. A versão V3 vem com 4 slots e é feita para o Arduino Uno). Pois não consigo fazer os motores girar.


Antes de mais nada quero esclarecer que tanto os motores quanto os drivers foram testados separadamente descartando assim qualquer problema com eles. O Arduino também foi testado a parte e não apresentou qualquer anomalia. Além disso acabei comprando uma Shield V3 com um Arduino Uno, e tudo funcionou perfeitamente!


Aí pesquisei um bocado e vi que em alguns casos as portas (pinagem) 2, 3 e 4 ficam invertidas com as 5, 6 e 7. Alterei no arquivo cpu_map_atmega328p. h as linhas correspontes (#39, #40, #41, #47, #48 e #49) mas de nada adiantou (estou usando o GRBL 0.9).


Alguém do fórum já passou por isso? Ou tem idéia do que poderia estar acontecendo?


Agradeço desde já a colaboração de todos.


Grande abraço e boa usinagem!