Autor Tópico: Mach 3 perdendo posição nos arcos.  (Lida 2533 vezes)

Description:

0 Membros e 1 Visitante estão vendo este tópico.

Offline Cássio Alvarenga

  • Moderador
  • CNCMASTER
  • ******
  • Posts: 3429
  • Sexo: Masculino
    • www.vatech.ind.br
  • Cidade - UF: Belo Horizonte - MG
  • Profissão: Empresario / Engenheiro Mecânico
Mach 3 perdendo posição nos arcos.
« Online: 21 de Maio de 2015, 17:44 »
Dei um update na minha fresadora e coloquei 3 servos, troquei a CPU, castanha, refiz alinhamento, etc...

 Instalei o mach3 no pc recem formatado e ele trabalha tranquilo em G-codes sem arcos, porem em G-codes com arcos ele perde um passo para o "X-" E a usinagem sai assim:

https://www.dropbox.com/s/p660xx7neagpzkb/2015-05-21%2017.26.13.jpg?dl=0

https://www.dropbox.com/s/22uiok8cih3giy7/2015-05-21%2017.26.31.jpg?dl=0

https://www.dropbox.com/s/dz1rm73mqrab12o/2015-05-18%2012.07.11.jpg?dl=0


Só vai para esse lado "X-" o resto é tranquilo, executei outros cortes e mesma coisa, da esses degrais.



Amanha vou conferir a configuração direitinho, alguém já teve esse problema?



Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Re:Mach 3 perdendo posição nos arcos.
« Resposta #1 Online: 21 de Maio de 2015, 17:56 »
na janela configurações, aba portas e pinos - motor outputs experimente marcar as opções "step low active" dos tres eixos...

tá parecendo que há perda de um passo sempre que os motores mudam de direção, e o efeito é este mesmo que aparece nas fotos

Offline Cássio Alvarenga

  • Moderador
  • CNCMASTER
  • ******
  • Posts: 3429
  • Sexo: Masculino
    • www.vatech.ind.br
  • Cidade - UF: Belo Horizonte - MG
  • Profissão: Empresario / Engenheiro Mecânico
Re:Mach 3 perdendo posição nos arcos.
« Resposta #2 Online: 21 de Maio de 2015, 18:47 »
Amanha vou tentar, mas só ocorre no X, todos os eixos estão igualmente configurados e possuem, drivers, motores e ligações idênticas.

Offline viumau

  • Hobby
  • ****
  • Posts: 577
  • Sexo: Masculino
  • Cidade - UF: São Bernardo do Campo
  • Nome:: Maurício Dias
  • Profissão: Consultor Técnico Automotivo
Re:Mach 3 perdendo posição nos arcos.
« Resposta #3 Online: 22 de Maio de 2015, 08:59 »
Olá Cássio, também já tive esse problema em 3 máquinas e foram ocasionados de maneiras diferentes, uma era falta de terra entre a controladora a Bob e o Pc, a outra era problemas com a Bob deixei direto e o problema já era, e a outra era problema com o Pc ele dava um leve choque sem sua carcaça o que resultava em perda de 1 passo em um sentido de giro do motor. Dá uma conferida nesses itens e veja se te ajuda...  ;)

Offline Cássio Alvarenga

  • Moderador
  • CNCMASTER
  • ******
  • Posts: 3429
  • Sexo: Masculino
    • www.vatech.ind.br
  • Cidade - UF: Belo Horizonte - MG
  • Profissão: Empresario / Engenheiro Mecânico
Re:Mach 3 perdendo posição nos arcos.
« Resposta #4 Online: 22 de Maio de 2015, 16:24 »
Fiz o que o Fabio falou e prestou.

Só acho estranho o PC esta ligado no sinal alto do driver (Pul +, Dir +) e o Pul -, Dir - no GND da fonte e o mach3 ter que ser configurado com step low active.  ::)

 
« Última modificação: 22 de Maio de 2015, 16:26 por Cássio Alvarenga »

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Re:Mach 3 perdendo posição nos arcos.
« Resposta #5 Online: 23 de Maio de 2015, 09:01 »
Cassio,

Não confunda as coisas - provavelmente está vendo a nomenclatura de ligação no drive, mas esta não tem nada a haver com o que fizemos.

Mexemos no sinal, mais precisamente na forma que o sinal é gerado - por se tratar de um sinal como uma onda quadrada, dissemos se ele começa em nivel alto ou baixo apenas.

Cada drive tem uma necessidade de condicionamento de sinal - uns esperam nivel alto e outros nivel baixo para um ciclo completo!

Quando o sinal está errado para o drive, acontece a perda de um pulso sempre que o drive inicia um movimento qualquer.

Na somatoria dá o efeito que voce experimentou - bastou acertar o nivel do sinal que o problema se resolveu

Offline Cássio Alvarenga

  • Moderador
  • CNCMASTER
  • ******
  • Posts: 3429
  • Sexo: Masculino
    • www.vatech.ind.br
  • Cidade - UF: Belo Horizonte - MG
  • Profissão: Empresario / Engenheiro Mecânico
Re:Mach 3 perdendo posição nos arcos.
« Resposta #6 Online: 23 de Maio de 2015, 11:59 »
Entendo,

Na documentação do driver diz que se pode acionar das 2 maneiras (baixo ou alto)...

Para usar sinal alto, liga-se os sinais negativos Pul-  Dir- no negativo da fonte e os Pul+ e Dir+ na lpt.

Para usar em sinal baixo liga-se o Pul + e Dir + no 5V da fonte e o Pul- e Dir- no Lpt.

Creio que eu esteja confundindo, liguei da primeira maneira (sinal alto, segundo o manual) penso que ele ATIVA o passo quando esta em sinal alto e fica em "standby" ou "idle" em sinal baixo. Mas o que fizemos é o contrario deixar ele em sinal ALTO em "standby" e da o passo em sinal baixo.


Offline ISAIASMCB

  • Novato
  • *
  • Posts: 2
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: SAO LOURENÇO DO SUL - RS
  • Nome:: ISAIAS VERNETTI DA SILVA
  • Profissão: MESTRE DE CABOTAGEM
Re:Mach 3 perdendo posição nos arcos.
« Resposta #7 Online: 09 de Junho de 2019, 14:44 »
Cassio,

Não confunda as coisas - provavelmente está vendo a nomenclatura de ligação no drive, mas esta não tem nada a haver com o que fizemos.

Mexemos no sinal, mais precisamente na forma que o sinal é gerado - por se tratar de um sinal como uma onda quadrada, dissemos se ele começa em nivel alto ou baixo apenas.

Cada drive tem uma necessidade de condicionamento de sinal - uns esperam nivel alto e outros nivel baixo para um ciclo completo!

Quando o sinal está errado para o drive, acontece a perda de um pulso sempre que o drive inicia um movimento qualquer.

Na somatoria dá o efeito que voce experimentou - bastou acertar o nivel do sinal que o problema se resolveu


MUITO   OBRIGADO  POR  ESCLARECER  TANTAS  DUVIDAS  !