Autor Tópico: Problema para movimentar a máquina  (Lida 1885 vezes)

Description:

0 Membros e 1 Visitante estão vendo este tópico.

Offline Rômulo Ximenes Mortari

  • Novato
  • *
  • Posts: 5
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: Santa Maria / Rio Grande do Sul
  • Nome:: Rômulo Ximenes Mortari
  • Profissão: Técnico em Mecânica
Problema para movimentar a máquina
« Online: 15 de Março de 2018, 16:48 »
Boa tarde!
Estou com problemas para o funcionamento de uma CNC.
Estou usando uma placa ESS da Warp9. Tudo parece funcionar muito, porém quando ponho a executar no modo automático, ela não funciona.
A máquina realiza o ciclo completo do sensor de altura. A tocha desce, toca na chapa, abre o arco, aciona a entrada 1, só que não libera o movimento
Alguém poderia dar alguma dica de como resolver esse problema



Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Re:Problema para movimentar a máquina
« Resposta #1 Online: 15 de Março de 2018, 17:19 »
Esta placa é que versão? e que versão de sw?

está com sinal de Plasma OK vindo da fonte para o Mach3?

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Re:Problema para movimentar a máquina
« Resposta #2 Online: 15 de Março de 2018, 17:36 »
Outra pergunta - é uma placa USB ou Ethernet - Que eu saiba placas USB não funcionam com Plasma - só Ethernet

Offline Rômulo Ximenes Mortari

  • Novato
  • *
  • Posts: 5
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: Santa Maria / Rio Grande do Sul
  • Nome:: Rômulo Ximenes Mortari
  • Profissão: Técnico em Mecânica
Re:Problema para movimentar a máquina
« Resposta #3 Online: 16 de Março de 2018, 08:12 »
Essa placa usa sistema Ethernet.
Tudo funciona normal, tanto que inclusive fiz uma breve alteração na macro M03 para comprovar isso
O que acontece é que ao clicar no executar, a tocha toca na chapa, faz o recuo, ativa a entrada 1 do mach 3 para fazer a movimentação, no entanto a máquina não se movimenta

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Re:Problema para movimentar a máquina
« Resposta #4 Online: 16 de Março de 2018, 08:34 »
O que está configurado na entrada 1?

Offline Rômulo Ximenes Mortari

  • Novato
  • *
  • Posts: 5
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: Santa Maria / Rio Grande do Sul
  • Nome:: Rômulo Ximenes Mortari
  • Profissão: Técnico em Mecânica
Re:Problema para movimentar a máquina
« Resposta #5 Online: 16 de Março de 2018, 08:53 »
A entrada 1 é o que libera o movimento
Na realidade o que acontece.... A placa de sensor de altura que manda o sinal para ativar a entrada 1.
A entrada aparece acionada no MACH3, porém ela não executa o código.
Tanto a entrada está certa que quando eu mudei o código M03 ela andou


A macro M03 é configurada da seguinte forma:
DospinCW - manda a tocha descer
Systemwaitfor(18) => aqui espera o sinal de retorno da placa de sensor de altura e após isso aciona a entrada 1 para liberar o movimento
No entanto nessa situação a máquina congela


Ai eu fiz uma alteração e o escrevi da seguinte forma
DospinCW
ActivateSignal(INPUT1)
Aqui ele movimenta, porém ele não faz o tempo correto de perfuração pré programado pela placa       

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Re:Problema para movimentar a máquina
« Resposta #6 Online: 16 de Março de 2018, 09:04 »
Veja só - quem libera ou não a movimentação do cnc é um sinal proveniente da fonte de plasma quando a tocha está acesa e estabilizada - este sinal de entrada é o "THC ON" (que na minha Opinião deveria se chamar Arc OK)....

Quando voce alterou a macro de "systemwaitfor" para "activatesignal", provavelmente simulou esta entrada - daí o cnc foi liberado...

É preciso ver se sua fonte de pasma tem disponível este sinal (de arc OK) - sem ele pode-se fazer um arranjo com um relé ou trabalhar "às cegas" isto é - ignorar o sinal de plasma presente, mas corre-se o risco de se o disparo falhar a maquina continua funcionando - perde-se tempo e material...

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Re:Problema para movimentar a máquina
« Resposta #7 Online: 16 de Março de 2018, 09:05 »
Para executar as coisas nos tempos corretos, é preciso uma macro que faça o que voce deseja - me parece que voce está apanhando porque sua macro não executa o que deveria

Offline Rômulo Ximenes Mortari

  • Novato
  • *
  • Posts: 5
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: Santa Maria / Rio Grande do Sul
  • Nome:: Rômulo Ximenes Mortari
  • Profissão: Técnico em Mecânica
Re:Problema para movimentar a máquina
« Resposta #8 Online: 16 de Março de 2018, 09:14 »
Como seria o modelo desta macro?
Eu já uso o sistema de relés as cegas
Agradeço se possível

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Re:Problema para movimentar a máquina
« Resposta #9 Online: 16 de Março de 2018, 09:46 »
Como seria o modelo desta macro?
Veja - a macro listada aqui faz uso de alguns DROs de usuário que devem ser criados na pela principal do Mach3 Plasma - nelas se informam a altura de furação, tempo de pausa e Altura de Compensação do sensor...

Veja ainda que nesta macro de exemplo estou usando um sinal de saída (output#6) que serviu para ligar/desligar um relé de isolamento de sinal, pois se trata de um plasma com contato ôhmico entre bico e chapa - este isolamento é necessário para evitar queima da interface.

Código: [Selecionar]
'*************************************************************
' TITULO :M3.M1S
'*************************************************************
' MÁQUINA :
' FABRICANTE :
' CLIENTE :
' CNC :
' FONTE PLASMA :HYPERTHERM POWERMAX 1250
' CRIADO EM :12/06/2008 POR: FABIO GILII - START UP
' ATUALIZADO EM :   
'*************************************************************

Option Explicit
Dim PIERCE, ALTSENSOR, PAUSE
PIERCE = GetOEMDRO( 1112 )
ALTSENSOR = getUserDRO (1111)
PAUSE = GetOEMDRO( 1110 )
ActivateSignal(OUTPUT6)
CODE "G92 Z0"
CODE "G31 Z-100 F250"
While ISMOVING()
Wend
DeActivateSignal(OUTPUT6)
CODE "G92 Z0"
While ISMOVING()
Wend
CODE "G0 Z" & PIERCE
While ISMOVING()
Wend
resetthc()
DoSpinCW()
Code"G4P" & PAUSE
CODE "G0Z" & ALTSENSOR

'*************************************************************
'    [url=http://WWW.GUIACNC.COM.BR]WWW.GUIACNC.COM.BR[/url]
'*************************************************************



Citar
Eu já uso o sistema de relés as cegas
Descreva como estes relés estão operando... Normalmente pode-se usar um relé para que quando se envia o sinal de ligar o plasma, o relé atraca e passa a enviar um sinal para a interface (e o cnc consequentemente) que o arco está OK e estável.
« Última modificação: 16 de Março de 2018, 09:49 por F.Gilii »

Offline Rômulo Ximenes Mortari

  • Novato
  • *
  • Posts: 5
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: Santa Maria / Rio Grande do Sul
  • Nome:: Rômulo Ximenes Mortari
  • Profissão: Técnico em Mecânica
Re:Problema para movimentar a máquina
« Resposta #10 Online: 16 de Março de 2018, 10:08 »
Essa macro seria meu novo M03?

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Re:Problema para movimentar a máquina
« Resposta #11 Online: 16 de Março de 2018, 10:14 »
Vamos lá - eu estou tentando explicar que cada máquina é uma maquina - depende de uma serie de detalhes, como por exemplo "COMO" sua eletrônica está ligada ao CNC... daí a macro do exemplo (sim, é a macro M3 que deveria ser substituída por essa) DEVE ser alterada CONFORME a necessidade... não quer dizer que como está vá funcionar...

Este exemplo faz uso de DROs criados e de conexões elétricas e circuitos específicos - repito - não quer dizer que vai funcionar assim como está...

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Re:Problema para movimentar a máquina
« Resposta #12 Online: 16 de Março de 2018, 10:20 »
Esta macro espera:

- um sinal (de entrada) para PROBE
- um sinal (de entrada) para "ARC OK" (que vem da fonte e avisa o CNC que o arco está ligado)
- um sinal (de saída) que liga/desliga um relé de ISOLAMENTO, pois o "PROBE" usa o bico da tocha para fazer contato com a chapa... cuidado

- um DRO para "Altura de Furação"
- um DRO para "Tempo de Furação"
- um DRO para "Altura de compensação" caso use uma mesa flutuante e contato seco ao invés de Probe de contato ôhmico...

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Re:Problema para movimentar a máquina
« Resposta #13 Online: 16 de Março de 2018, 12:15 »
E claro - dois sinais (de entrada) para o eixo Z subir/descer...

Offline lucasmurieto

  • Novato
  • *
  • Posts: 2
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: sc
  • Nome:: lucas
  • Profissão: operador de maquinas
Re:Problema para movimentar a máquina
« Resposta #14 Online: 22 de Abril de 2020, 13:57 »
boa tarde.


Pessoal eu li diversas vezes os comentários mas não consegui encaixar na minha situação.
A configuração que estou usando é o da tecnopampa tecnopampa. mudei apenas steps / portas e pinos o basico....
Eu rodo o mach 3  na opção de OXI-corte funciona perfeitamente, inicia o corte ate o ponto de perfuração e espera ate que eu aperto  F 5 para perfurar a chapa e P para executar a linha, ate ai perfeito!. Quando eu executo  mach 3  na opção de plasma ele chega no ponto de perfuração, o plasma dispara mas não executa a próxima linha ate que eu aperte a letra P. tenho que ficar apertando a letra p para executar todas as linhas.