Autor Tópico: Tutorial Sobre Acionamento de Motor de Passo  (Lida 60497 vezes)

Description:

0 Membros e 1 Visitante estão vendo este tópico.

reinaldoaf

  • Visitante
Tutorial Sobre Acionamento de Motor de Passo
« Online: 26 de Março de 2007, 08:34 »
Galera...

O driver do cicuto que eu montei acionando um motor 23lm608 se nao me engano com 24v, o problema é que eu regulei os drivers em uma fonte barrela, e ai quando coloquei na minha q parece um monstro queimei os fet tudo, vo precisar comprar outros :(

link:


ps: Acionado a meio passo!
Freq: 55000Hz ou 55kHz
Acionamento: Meio Pasoo (400 passos / volta)
RPM: 8250

Abraços



Offline fsemonetti

  • Fuso
  • **
  • Posts: 186
Tutorial Sobre Acionamento de Motor de Passo
« Resposta #1 Online: 26 de Março de 2007, 09:03 »
reinaldoaf,
Citar
, o problema é que eu regulei os drivers em uma fonte barrela, e ai quando coloquei na minha q parece um monstro queimei os fet tudo

não entendi o motivo que queimou os fet's, e que tenho uma placa do cicuto e gostaria de tomar as precauções,??

reinaldoaf

  • Visitante
Tutorial Sobre Acionamento de Motor de Passo
« Resposta #2 Online: 26 de Março de 2007, 09:44 »
Seguinte,

A regulagem do tripot,
ela é feita pra alimentar os motores, como a fonte era muito fraca, eu regulei com cerca de 2,8v (meu multimetro é analogico) entao quando coloquei em uma fonte forte, que consegue alimentar os 3 motores sem problemas, ele queimou os fet's pois a corrente, foi alta, entendeu?

abraços

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Tutorial Sobre Acionamento de Motor de Passo
« Resposta #3 Online: 26 de Março de 2007, 09:50 »
Reinaldo,

Quais as características desse motor?

reinaldoaf

  • Visitante
Tutorial Sobre Acionamento de Motor de Passo
« Resposta #4 Online: 26 de Março de 2007, 10:17 »
Uhn!!! Aperto sem abraço,

ai vai o que eu tenho, eles nao estao comigo nao lembro corretamente a definição do cara.
se nao me engano é um dos dois fábio!!
abraços
MODELO      GRADOS VOLT.  AMP.   OHM    PAR
23LM-C706  1,8          2,7      2,70   1,00     7 kg/cm
23PM-C406  1,8          4,3      1,90   2,20     8 kg/cm


editado por mim
Confirmado é o 406

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Tutorial Sobre Acionamento de Motor de Passo
« Resposta #5 Online: 26 de Março de 2007, 10:21 »
Reinaldo,

Voce fala em um 23LM608 (não conheço com esta numeração) - depois fala em dois outros modelos diferentes, sendo que nenhum deles usa 2,8A/fase...

Não dá para entender...

Quais são os FETs usados na placa?

Acho muito dificil ser algum problema com a corrente consumida, mas...

reinaldoaf

  • Visitante
Tutorial Sobre Acionamento de Motor de Passo
« Resposta #6 Online: 26 de Março de 2007, 10:31 »
Fábio,

Acho que está enganado 2,8 v(volts) nao 2,8A
quanto a  numeração do motor foi um engano mesmo..
é o 23PMC406

O referido é, a placa do cicuto suporta 5A se nao me engano, com o acionamento a meio passo eu preciso diminuir o valor do pino 15 do L297 pois ele consome mais que 5A e se o valor estiver em uma regulagem "correta" vai fritar os IRF540, quando eu regulei em 2,8v na entrada do pino 15 do L297 atravez do Tripot, eu estava utilizando uma fonte que não conseguia me fornecer a correte correta para os motores, entao mesmo eu regulando acima não havia problema pois não tinha a corrente, quando eu liguei na minha fonte que consegue fornecer básicos 24V 90A, o resultado foi vários fet's queimados!

entendido o motivo dos fets queimarem? foi manezada do oreia seca aqui!

abraços

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Tutorial Sobre Acionamento de Motor de Passo
« Resposta #7 Online: 26 de Março de 2007, 10:38 »
Reinaldoaf,

Como não conheço o circuito do Fabio Cicuto, penso que "se" os resistores "rsense" forem de 0,1 ohm, se medir o pino 15 do L297 com 2,8 V (conforme voce escreveu) estará mandando 28 Ampere para o motor.

Se for um resistor de 0,22 ohm, com os mesmos 2,8V (conforme voce escreveu), estará enviando 12,72 Ampere para o motor...

Se os resistores forem de 0,47 ohm, e está medindo os mesmos 2,8V (conforme voce escreveu), estará enviando 5,95 Ampere para o motor...

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Tutorial Sobre Acionamento de Motor de Passo
« Resposta #8 Online: 26 de Março de 2007, 10:40 »
Acho que além dos FETs, o motor já deveria ter subido aos céus dos motores há muito tempo - bem antes que os coitados dos FETs, que também não tem culda no cartório...

reinaldoaf

  • Visitante
Tutorial Sobre Acionamento de Motor de Passo
« Resposta #9 Online: 26 de Março de 2007, 10:51 »
Fábio, pior que nao, pq os motores nem chegam a esquentar e o fet torra...

agora q eu tava vendo aque direito os valores... realmente é isso estou fritando os fets....

vou ver se faço o esquema com o LM2917 :D

abraços

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Tutorial Sobre Acionamento de Motor de Passo
« Resposta #10 Online: 26 de Março de 2007, 11:01 »
Reinaldo,

Veja bem... não é uma questão de usar um conversor de frequencia-tensão...  O problema persiste:

A tensão medida no pino 15 do L297 é regulada em função do Rsense usado no circuito.

Mesmo usando o tal circuitinho, o problema vai continuar - do jeito que voce descreveu, está medindo (e ajustando) uma tensão MUITO grande...

reinaldoaf

  • Visitante
Tutorial Sobre Acionamento de Motor de Passo
« Resposta #11 Online: 26 de Março de 2007, 11:49 »
É fábio,

Só que via de regra, sabe-se que o consumo de corrente pelo motor é diretamente proporcional a frequencia, se eu conseguir aumentar a "liberação" de corrente atravez a medida q aumenta a frequencia eu vou ter uma corrente bem baixa em poucos hz e bem alta em grandes velocidades, o que no caso pode ser interessante...

pois com o motor parado eu posso regular apenas 250mA que é o suficiente pra manter o hold torque, e a uns 3000hz (9000mm/min) que seria minha velocidade máxima que poderia ser utilizada para traslados "G00" eu poderia mandar uns 3v que seria o mesmo que disponibilizar 9A para o motor Vref = 0.33 x Amotor => 3v = 0,33 x A => A=3/0,33 = 9,09A

e nao correria o risco de queimar o FET pois o tempo que ele ficaria acionado é tao rápido que nao dá nem pra esquentar...

abraços

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Tutorial Sobre Acionamento de Motor de Passo
« Resposta #12 Online: 26 de Março de 2007, 12:02 »
É Reinaldo,

Em parte pode ser interessante, mas a realidade é que se colocar os 3V de referencia no pino 15 do L297 quando a frequencia de aciuonamento estiver a "X" Hz, vai continuar fritando FET e provavelmente vai fritar algum motor...

Não interessa muito o tempo de acionamento do FET, se fizer circular mais corrente do que ele suporta, babau...

Mas como sempre, posso estar enganado, e esta foi só minha opinião...

reinaldoaf

  • Visitante
Tutorial Sobre Acionamento de Motor de Passo
« Resposta #13 Online: 26 de Março de 2007, 12:30 »
O Fet suporta 50A se nao me engano fábio, o problema é quando o motor está parado, que ele vai esquentar muito...

reinaldoaf

  • Visitante
Tutorial Sobre Acionamento de Motor de Passo
« Resposta #14 Online: 27 de Março de 2007, 09:06 »
Fábio,

Somente para constar, realmente o problema era a regulagem, troquei os fets queimados e foi batata, o trem ta funcionando que é uma beleza, agora eu vou assim que puder, montar o esquema com o LM2917 o problema é que ele é bem carinho 28 rurais aqui... eu procurei o LM2917M-8 ou LM2907M-8 mais nao encontrei esse ai é um CI de 8 pinos, bem mais simples de utilizar que o irmao maior dele :D

Abraços