Autor Tópico: zero automatico  (Lida 236 vezes)

Description:

0 Membros e 1 Visitante estão vendo este tópico.

Offline [email protected]

  • Novato
  • *
  • Posts: 1
  • Sexo: Masculino
  • Forum GUIA CNC - A Maior comunidade CNC do Brasil
  • Cidade - UF: mortugaba bahia
  • Nome:: claudinei
  • Profissão: marceneiro
zero automatico
« Online: 05 de Março de 2018, 19:11 »
Olá, meu nome é Ney.  tenho uma cnc configurei o alto tool quando abro o mach3 clico em alto tool ele funciona blza desse devagar toca a sonda tudo certo ... porém quando carrego um outro g code e clico pra zerar ele desse rapido toca a sonda pausa  e sobe sobe rapido ate bater o carrinho... fecho mach3  e abro novamente funciona normal... se alguém puder me ajudar por favor ficarei grato.  uso esse            '-------------------CurrentFeed = GetOemDRO(818) DoSpinStop() ZMove = 20.00 'Distância na qual a maquina procura a sonda. No caso, ela desce 2 cm antes de abortar ZOffset = 1.60 ' Altura da sua placa ZSal = ZOffset + 2.00 'Depois que a sonda faz contato, ela sobe 2 mm + a altura da sonda. StopZmove = 0 If GetOemLed (825)=0 Then DoOEMButton (1010) Code "G4 P2.5" Code "G31 Z-"& ZMove & "F25" While IsMoving() Sleep(200) Wend Probepos = GetVar(2002) If Probepos = - ZMove Then responce = MsgBox ("**ERRO** " , 4 , "Erro na sonda" ) Code "G0 Z10" StopZmove = 1 Code "F" &CurrentFeed End If If StopZmove = 0 Then Code "G0 Z" & Probepos While IsMoving () Sleep (200) Wend Call SetDro (2, ZOffset) Code "G4 P1" Code "G0 Z" & ZSal Code "(Z zeroed)" Code "F" &CurrentFeed End If Else Code "(Check Ground Probe)" End If Exit Sub '-------------------