Autor Tópico: NC Studio  (Lida 1136 vezes)

Description:

0 Membros e 1 Visitante estão vendo este tópico.

Offline alissonneia

  • Novato
  • *
  • Posts: 2
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: Mandaguaçu - PR
  • Nome:: Alisson Néia
  • Profissão: Empresário
NC Studio
« Online: 17 de Agosto de 2018, 11:25 »
Olá, estou começando a trabalhar com CNC agora, e estou com muitas dúvidas.
Estou usando Aspire para edição e criação do material e o NC Studio na máquina!
Faz dias que estou tentando cortar um modelo teste e não consigo, os parâmetros estão todos corretos acredito eu, altura da chapa, fresa etc..
Mas quando jogo o arquivo no NC Studio ele não obedece os comando corretamente, sobe o motor Z acima do limite, estou achando que é configuração dele,
já mudei várias configurações e ainda não consegui, agora nem voltar pras configurações padrão eu sei, algum pode me ajudar ?
Obrigado desde já!

Minha máquina -> (CNC ROUTER LAMPE - AM2030)



Offline A.Hoffmann

  • Novato
  • *
  • Posts: 81
  • Sexo: Masculino
  • GUIA CNC
  • Cidade - UF: Lajeado - RS
  • Nome:: Adilson
  • Profissão: Operador e Programador Centro de Usinagem
Re:NC Studio
« Resposta #1 Online: 19 de Agosto de 2018, 20:48 »
Boa noite Alisson, tudo certo?


Fica um pouco complicado diagnosticar o problema exato, sem ver o código que você gerou no aspire para o NC rodar... se puder, copia o código e cole aqui pro pessoal poder ajudar melhor.


Vamos por etapas: Se o NC está com a configuração de fábrica da máquina, dificilmente o problema estava aí... mas, como você mencionou que mexeu nas configs. É bom verificar se não deixou nada "fora do lugar". Se você fez um backup das configurações antes de alterar, tranquilo, caso não tenha feito, seria interessante uma ajuda do suporte do fabricante.


Meu palpite é que o problema esteja no arquivo gerado pelo aspire, pode ser que essa subida extra do eixo Z seja um Z seguro não configurado, usando algum valor padrão... pode ser que o pós-processador que você está utilizando não é o certo...


Faz um tempinho que não uso mais o NC, mas pelo que me lembro, ele roda bem com um pós ISO (no Artcam eu usava o .NC e era necessário apagar as primeiras linhas pra não dar erro).


Att.


Adilson

Offline alissonneia

  • Novato
  • *
  • Posts: 2
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: Mandaguaçu - PR
  • Nome:: Alisson Néia
  • Profissão: Empresário
Re:NC Studio
« Resposta #2 Online: 20 de Agosto de 2018, 17:54 »
Olá Hoffmann, vou colar o código pra ver se conseguem me ajudar!


Eu ainda estou estudando o Aspire e o NC, como disse ainda estou começando e minha máquina está parada porque ainda não consegue resolver esse problema!
Muito obrigado por enquanto!

Código em anexo!

Offline A.Hoffmann

  • Novato
  • *
  • Posts: 81
  • Sexo: Masculino
  • GUIA CNC
  • Cidade - UF: Lajeado - RS
  • Nome:: Adilson
  • Profissão: Operador e Programador Centro de Usinagem
Re:NC Studio
« Resposta #3 Online: 23 de Agosto de 2018, 22:18 »
Boa noite Alisson,


Sobre o código, vou colar um trecho dele aqui e colocar algumas anotações...



o0001
( Letra_P )
N20 G91 (modo de coordenadas incremental ativado) G28  X0.000 Y0.000 Z3.010 (esse comando manda a maquina para home position ou seja, "0 máquina" o ponto de referência de todos os eixos... mas note que em Z ele está mandando a máquina subir além da posição 0... aqui está o problema com a subida estranha do eixo Z)
N30 G00 G21 G17 G90 (ok)
N40 G00 G40 G49 G80 (ok)
N50 G71(ok)
N60 T1 M06 (comando para a máquina carregar a ferramenta automaticamente... sua máquina tem troca de ferramenta automática??)
N70 G00 G43Z3.010H1 M8(o comando G43 ativa a correção de comprimento da ferramenta... só faz sentido se a máquina tiver a troca automática...Com a ferramenta devidamente medida e cadastrada no corretor H1... O comando M08 serve para ligar o liquido de arrefecimento)
N80 S15000 M03(rotação 15000... o comando M03 significa ligar a rotação no sentido horário, mas dependendo da máquina ele somente aciona o relé para ligar o spindle)


Considerações:


Se você fizer algumas alterações manuais, este arquivo deve rodar... na linha N20 apague o Z3.010 e coloque Z0... Se a sua máquina não tiver troca automática de ferramentas, apague as linhas N60 e N70 (mantenha somente somente o comando M08, caso sua máquina possua sistema de arrefecimento e se for aplicável o uso na peça em questão... senão, pode apagar ele também).


Att.


Adilson



Desculpe por repetir a postagem anterior, mas tive algum problema ao usar a formatação do editor...