Autor Tópico: Perda de passo, problema nos Drivers e troca da eletrônica  (Lida 399 vezes)

Description:

0 Membros e 1 Visitante estão vendo este tópico.

Offline DiegoPossa

  • Novato
  • *
  • Posts: 8
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: Bagé - RS
  • Nome:: Diego
  • Profissão: Engenheiro
Perda de passo, problema nos Drivers e troca da eletrônica
« Online: 09 de Novembro de 2019, 13:17 »
Boa tarde pessoal, sou novo aqui no fórum e também no assunto de CNC e gostaria do auxílio de vcs.


Minha máquina está perdendo passos. Como é possível ver na imagem abaixo, depois de executar um código ela não retorna exatamente ao ponto de origem.








Acredito não ser problema de folga pois me preocupei bastante com isso além de que o deslocamento varia conforme o driver. Um sempre apresenta resultado bom, outros muito ruins. Quando deixei ligado apenas o eixo X ligado e rodei o código, para cada driver testado obtive um resultado diferente, sendo que o melhor o deslocamento ficou aproximadamente em 0,2mm e o pior 10mm.


Detalhe, esse problema ocorre sempre para o mesmo lado, não importando o desenho a menos que seja alterado a ligação das bobinas do motor de passo, nesse caso o deslocamento fica na direção contrária, como é possível ver nas imagens anteriores.
De qualquer forma seguem algumas imagens da máquina.





A descrição da máquina é a seguinte
  • 4 motores nema 23 de 24Kgf.cm (dois no eixo Y)
  • 4 Drivers tb6600 chineses
  • 1 fonte 24V e 240W
  • Controle através do Arduino usando GRBL
Para o tamanho da CNC (3x2m) e o peso dela os motores estão fracos assim como os drivers, então peço o auxílio de vcs se a configuração que pretendo adquirir é suficiente.
Resumindo tudo, minha dúvidas são: O trafo é uma boa opção para esses drivers? Preciso de algum circuito eletrônico adicional ou apenas posso ligar os drivers no trafo? Acreditam que a perda de passos é apenas devido aos drivers?


Desde já meu agradecimento a todos
« Última modificação: 11 de Novembro de 2019, 09:27 por Guia CNC »



Offline DiegoPossa

  • Novato
  • *
  • Posts: 8
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: Bagé - RS
  • Nome:: Diego
  • Profissão: Engenheiro
Re:Perda de passo, problema nos Drivers e troca da eletrônica
« Resposta #1 Online: 09 de Novembro de 2019, 13:26 »
Pessoal, as imagens não apareceram no tópico, então seguem elas





« Última modificação: 11 de Novembro de 2019, 09:25 por Guia CNC »

Offline DiegoPossa

  • Novato
  • *
  • Posts: 8
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: Bagé - RS
  • Nome:: Diego
  • Profissão: Engenheiro
Re:Perda de passo, problema nos Drivers e troca da eletrônica
« Resposta #2 Online: 09 de Novembro de 2019, 13:31 »
Imagens por outros sites não estão carregando, e a pré-visualização também não. Tentando pelo servidor do fórum. Peço desculpa por todas mensagens.

Offline luciano g

  • Hobby
  • ****
  • Posts: 869
  • Sexo: Masculino
Re:Perda de passo, problema nos Drivers e troca da eletrônica
« Resposta #3 Online: 09 de Novembro de 2019, 15:50 »
Provavel ser sujeira nas gremalheiras
luciano

Offline DiegoPossa

  • Novato
  • *
  • Posts: 8
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: Bagé - RS
  • Nome:: Diego
  • Profissão: Engenheiro
Re:Perda de passo, problema nos Drivers e troca da eletrônica
« Resposta #4 Online: 09 de Novembro de 2019, 16:17 »
Boa tarde Luciano, conforme mencionei a perda de passo não acontece com todos os drivers, então acredito não ser um problema mecânico. Por sinal tive vários problemas mecânicos como folgas e desalinhamentos que pelo que pude constatar foram resolvidos. A sujeira da cremalheira fica apenas abaixo de onde está passando o pinhão.
Você teria alguma outra ideia? Já trabalhou com trafo toroidal acoplados diretamente nos drivers?


Abraço

Offline vieirajp

  • Hobby
  • ****
  • Posts: 254
  • Sexo: Masculino
  • Forum GUIA CNC - A Maior comunidade CNC do Brasil
  • Cidade - UF: Fernandópolis
  • Nome:: Reginaldo Vieira
  • Profissão: Funcionario publico
Re:Perda de passo, problema nos Drivers e troca da eletrônica
« Resposta #5 Online: 10 de Novembro de 2019, 10:50 »
   Bom dia Amigo, tenho a mesma opinião do Luciano, a concepção da maquina não ajuda muito no meu ponto de vista, a posição da cremalheira não ajuda muito, eu não pensaria 2 vezes em mudar ela de lugar, colocando ela em baixo da mesa no centro usando apenas 1 e um único motor, protegendo da sujeira e cuidando do alinhamento impecável. como a maquina não é muito grande daria sem problemas. Muito justo avaliar um problema mecânico.
    Espero ter ajudado.

Offline DiegoPossa

  • Novato
  • *
  • Posts: 8
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: Bagé - RS
  • Nome:: Diego
  • Profissão: Engenheiro
Re:Perda de passo, problema nos Drivers e troca da eletrônica
« Resposta #6 Online: 10 de Novembro de 2019, 22:10 »
   Bom dia Amigo, tenho a mesma opinião do Luciano, a concepção da maquina não ajuda muito no meu ponto de vista, a posição da cremalheira não ajuda muito, eu não pensaria 2 vezes em mudar ela de lugar, colocando ela em baixo da mesa no centro usando apenas 1 e um único motor, protegendo da sujeira e cuidando do alinhamento impecável. como a maquina não é muito grande daria sem problemas. Muito justo avaliar um problema mecânico.
    Espero ter ajudado.


Boa noite vieirajp, a posição estava na lateral dá máquina, porém não conseguia linearidade dessa forma, precisei colocar na parte superior. Vou colocar um coletor de pó e um aparador para que o pó restante caia para baixo da mesa. Posso garantir que a sujeira não é um problema agora, pois estou realizando os teste com os trilhos limpos, sem cortar nada, além disso quando altero o driver que está movimentando aquele eixo o resultado fica quase perfeito. Realizei testes alterando o driver que comando o eixo X, deixando apenas esse driver ligado, sem tupia nem outros motores e o resultado é diferente para cada um. Um deles apresenta um resultado muito bom, outro razoável e outros dois péssimos.
Não consigo ver outra relação a não ser a qualidade dos driver, alguém teria outra possibilidade?
Além disso meus motores estão esquentando muito, acreditam que trocando apenas os drivers analógicos para digitais eu conseguiria reduzir a temperatura?
Caso troque os drivers, acreditam que os DMA860 são uma boa escolhas? Alguém já utilizou eles com corrente alternada fornecida por um trafo toroidal?
Obrigado

Offline vieirajp

  • Hobby
  • ****
  • Posts: 254
  • Sexo: Masculino
  • Forum GUIA CNC - A Maior comunidade CNC do Brasil
  • Cidade - UF: Fernandópolis
  • Nome:: Reginaldo Vieira
  • Profissão: Funcionario publico
Re:Perda de passo, problema nos Drivers e troca da eletrônica
« Resposta #7 Online: 11 de Novembro de 2019, 06:03 »
  Talvez um problema que pode te atrapalhar, e eu amarguei isso aqui é a interferência eletromagnética que dava sinais falsos com o uso de um inversor, talvez não seja seu caso, mas o fato de não usar cabos blindados para os motores pode ocasionar este tipo de problema. Eu tenho uma experiencia diária, com o pó e cavaco, trabalho basicamente com madeiras do tipo angico cumaru e outras bem dura e vou te dizer, pensa em um pó e cavaco na hora de plainar, para mim aqui não da para usar um sugador de pó constante  por causa do barulho, eu trabalho no fundo de casa e os vizinhos me expulsaria daqui. eu uso um driver CW5045 e nunca driver tive problema com aquecimento, ele trabalha com 36V minha fonte é chaveada de 400W a estrutura de minha maquina é pesada, algo em torno de 80Kg e uso apenas um motor em cada eixo com fuso de esfera com uma movimentação de 7 metros por minuto.

Offline luciano g

  • Hobby
  • ****
  • Posts: 869
  • Sexo: Masculino
Re:Perda de passo, problema nos Drivers e troca da eletrônica
« Resposta #8 Online: 11 de Novembro de 2019, 09:44 »
Tem probs nos 2 eixos


esperimenta mudar a resolução dos drives e


tenho maquima com tafo e fonte não me dão probs


luciano

Offline DiegoPossa

  • Novato
  • *
  • Posts: 8
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: Bagé - RS
  • Nome:: Diego
  • Profissão: Engenheiro
Re:Perda de passo, problema nos Drivers e troca da eletrônica
« Resposta #9 Online: 11 de Novembro de 2019, 13:53 »
  Talvez um problema que pode te atrapalhar, e eu amarguei isso aqui é a interferência eletromagnética que dava sinais falsos com o uso de um inversor, talvez não seja seu caso, mas o fato de não usar cabos blindados para os motores pode ocasionar este tipo de problema. Eu tenho uma experiencia diária, com o pó e cavaco, trabalho basicamente com madeiras do tipo angico cumaru e outras bem dura e vou te dizer, pensa em um pó e cavaco na hora de plainar, para mim aqui não da para usar um sugador de pó constante  por causa do barulho, eu trabalho no fundo de casa e os vizinhos me expulsaria daqui. eu uso um driver CW5045 e nunca driver tive problema com aquecimento, ele trabalha com 36V minha fonte é chaveada de 400W a estrutura de minha maquina é pesada, algo em torno de 80Kg e uso apenas um motor em cada eixo com fuso de esfera com uma movimentação de 7 metros por minuto.
Penso que interferência pode realmente ser um dos problemas, infelizmente não tenho osciloscópio para averiguar de uma forma mais precisa. Mas penso em comprar cabos blindados caso realmente necessite. Será que preciso colocar tanto na parte de sinal quanto na parte potência?
Aqui o pó fica brabo também, sem sugador precisa ficar com mascara direto. Minha máquina pesa uns 600Kg, só o pórtico pesa uns 40Kg, quando colocar o spindle de ir para uns 50kg. O problema é que estou usando a corrente limite nos motores (2A), quando ficam com 1,5A eles ficam um pouco fracos, mas talvez seja melhor deixar eles em 1,5 A e evitar que eles queimem.

Tem probs nos 2 eixos


esperimenta mudar a resolução dos drives e


tenho maquima com tafo e fonte não me dão probs


luciano




Já mudei a resolução, estou trabalhando em 1/8 de passo para evitar trepidação, com 1/2 passo a trepidação é muito grande. Quanto ao trafo você poderia dar alguma dica? Eles são mais em conta que as fontes e me parecem mais seguros, porém não encontrei muito material falando em ligar esse drivers digitais, que permitem entrada VCC e VCA, diretamente em um trafo. Será que é mais seguro utilizar uma fonte chaveada?


Abraço e obrigado pelas dicas

Offline vieirajp

  • Hobby
  • ****
  • Posts: 254
  • Sexo: Masculino
  • Forum GUIA CNC - A Maior comunidade CNC do Brasil
  • Cidade - UF: Fernandópolis
  • Nome:: Reginaldo Vieira
  • Profissão: Funcionario publico
Re:Perda de passo, problema nos Drivers e troca da eletrônica
« Resposta #10 Online: 12 de Novembro de 2019, 12:40 »

   a estrutura de minha maquina é pesada, algo em torno de 80Kg e uso apenas um motor em cada eixo com fuso de esfera com uma movimentação de 7 metros por minuto.


Na verdade me referi ao pórtico móvel com spidle




Aqui para resolver o problema com interferência eu fiz uma blindagem tabajara no cabo que liga o splindle ao inversor, diminuiu mas não resolveu por completo e ao fim usei filtros, que solucionou definitivamente, mas no seu caso os filtros não sera possível para os motores, talvez um bom cabo blindado mesmo e um aterramento exclusivo de umas 3 astes de profundidade, mas é bom investigar certinho.



Offline DiegoPossa

  • Novato
  • *
  • Posts: 8
  • Sexo: Masculino
  • GUIA CNC BRASIL
  • Cidade - UF: Bagé - RS
  • Nome:: Diego
  • Profissão: Engenheiro
Re:Perda de passo, problema nos Drivers e troca da eletrônica
« Resposta #11 Online: 13 de Novembro de 2019, 18:20 »
Boa tarde Vieirajp, acabei de comprar um spindle. Você poderia detalhar como fez os filtros e como fez essa blindagem?

Offline vieirajp

  • Hobby
  • ****
  • Posts: 254
  • Sexo: Masculino
  • Forum GUIA CNC - A Maior comunidade CNC do Brasil
  • Cidade - UF: Fernandópolis
  • Nome:: Reginaldo Vieira
  • Profissão: Funcionario publico
Re:Perda de passo, problema nos Drivers e troca da eletrônica
« Resposta #12 Online: 18 de Novembro de 2019, 08:21 »
Boa tarde Vieirajp, acabei de comprar um spindle. Você poderia detalhar como fez os filtros e como fez essa blindagem?


Nossa... só vi agora sua mensagem.

  Vamos lá adicionando um capacitor de poliester 100nf e um resistor 100 ohms 1/4w na entrada do sinal e gnd o capacitor funciona da seguinte forma, alta frequência termina em curto, assim filtrando o sinal, mas só vai bem no caso do botão E-Stop, nos drivers acho ue tem que adotar uma outra estrategia, porque não pode ter filtro se não o mesmo pode atrapalhar o sinal de pulso. Acho que é mais ou menos isso. O importante que deu certo e com uma estabilidade boa, no cabo do spindle, como na minha cidade não encontrei cabo blindado para comprar, usei um cabo de 4 vias e enrolei fita adesiva de alumínio e aterrei a mesma, no meu caso o problema agrava bastante porque meus cabos são compridos e isso não é bom, mas tive que usar assim para o sistema eletrônico ficar fora da poeira. Espero ter ajudado.