Autor Tópico: Problemas no Percurso REalizado  (Lida 6665 vezes)

Description:

0 Membros e 1 Visitante estão vendo este tópico.

Offline Neto g

  • Fuso
  • **
  • Posts: 112
  • Sexo: Masculino
  • Há uma maneira de faze-lo melhor: encontre-a.
  • Cidade - UF: Guarujá - São Paulo
  • Nome:: Nacim Gaze
Problemas no Percurso REalizado
« Online: 14 de Abril de 2012, 18:47 »
Pessoal Boa Tarde,

Estou tendo um problema com o percurso do Mach3, percebo que o trajeto da ferramenta está sendo alterado por alguma configuração do Mach3, o sintoma consiste em que a peça está com um aspecto bem diferente do que o planejado, até pelo prórpio MAch3, como se o mach3 não deixasse a ferramenta ir até à corrdenada final xyz, eu programei da  CNC fazer uma perfilagem  de 2mm em uma peça de 4mm e o mesmo ficou com uma parte da trajetória sem usinar. Por Fim, vou deixar algumas fotos, para que vocês tenham uma noção do que está acontecendo:

Eu fiz o percurso com o Artcam e Visualmill e as peças ficaram diferentes do mesmo jeito, por isso estou apostando em alguma configuração errada no Mach3

Um Abraço Nacim



Offline Jorge_BH

  • CNCMASTER
  • ******
  • Posts: 2504
  • Sexo: Masculino
  • Jorge Maluf Jacob
  • Cidade - UF: Belo Horizonte-MG
  • Profissão: Administrador de Empresas
Re:Problemas no Percurso REalizado
« Resposta #1 Online: 14 de Abril de 2012, 19:01 »
Olá.
Não tenho conhecimento do Mach3, mas parece ser problema com velocidade. Há um campo para configurar em que a ferramenta só começa a outra linha do percurso depois de terminar a anterior. Esse campo não deve estar setado, então com a velocidade de corte mais alta a ferramenta faz uma curva ao invés de ir até o final da linha.
Mas é só um pitaco.
Abraço.
Jorge

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Re:Problemas no Percurso REalizado
« Resposta #2 Online: 14 de Abril de 2012, 19:30 »
Experimente escrever no cabeçalho do arquivo o comando G61 e rode o arquivo - deveria funcionar.

Offline Neto g

  • Fuso
  • **
  • Posts: 112
  • Sexo: Masculino
  • Há uma maneira de faze-lo melhor: encontre-a.
  • Cidade - UF: Guarujá - São Paulo
  • Nome:: Nacim Gaze
Re:Problemas no Percurso REalizado
« Resposta #3 Online: 14 de Abril de 2012, 19:49 »
Jorge, qualquer ajuda é bem vinda eheheh, vou fazer o que o mestre Gilii falou e já volto com o resultado
Gilii, vou refazer essa peça e já volto


Abraços Nacim

Offline Neto g

  • Fuso
  • **
  • Posts: 112
  • Sexo: Masculino
  • Há uma maneira de faze-lo melhor: encontre-a.
  • Cidade - UF: Guarujá - São Paulo
  • Nome:: Nacim Gaze
Re:Problemas no Percurso REalizado
« Resposta #4 Online: 14 de Abril de 2012, 20:20 »
Caros Amigos
Coloquei o Código G61 no cabeçalho...e uma imagem vale mais que mil palavras!


Um detalhe, agora em qualquer curva,  ele está indo bem devagar, dá até pra ouvir aqueles "soquinhos" que o motor de passo dá, de tão devagar que está, isso é normal?

Obrigado pela ajuda Fábio (Em tempo, tem mandei uma MP perguntando sobre uma cotação de servos motores, continuo no aguardo!)

Jorge Obrigado Pela Ajuda Tbm

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Re:Problemas no Percurso REalizado
« Resposta #5 Online: 14 de Abril de 2012, 21:21 »
Não recebí não...

Quando for assim algo importante, escreva no meu e-mail por gentileza.

Offline Cássio Alvarenga

  • Moderador
  • CNCMASTER
  • ******
  • Posts: 3429
  • Sexo: Masculino
    • www.vatech.ind.br
  • Cidade - UF: Belo Horizonte - MG
  • Profissão: Empresario / Engenheiro Mecânico
Re:Problemas no Percurso REalizado
« Resposta #6 Online: 14 de Abril de 2012, 21:55 »
Fabio o que estava errado? o que o G61 faz?

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Re:Problemas no Percurso REalizado
« Resposta #7 Online: 15 de Abril de 2012, 07:53 »
A maioria dos programas de controle de máquinas tem um planejador de movimentos que usa dois modos de controle de movimentação - Parada exata (G61) e Velocidade Constante (G64).

O planejador de movimentos lê os movimentos que devem ser feitos antes de executá-los - é o que se chama "Look Ahead" (Lê na frente), e para entender melhor o que ele faz vamos imaginar um determinado caso - duas linhas retas a 90º uma da outra.

Em G61 o planejador simplesmente manda o eixo se mover na velocidade de avanço que foi pré definido no arquivo de corte até que a linha termine, então o eixo pára por completo, e começa a se movimentar sobre a outra linha porque a direção mudou conforme o exemplo proposto.

O resultado é um canto vivo e a movimentação pode ser um tando áspera.

Em G64, o planejador manda o eixo se mover na velocidade de avanço, mas quando está chegando no ponto de mudar de direção ele faz uma diminuição na velocidade deste eixo e começa a movimentar o outro eixo para fazer a mudança de direção.

O resultado é uma pequena curva e uma movimentação mais suave.

Em programas como EMC ou Mach3 há como se ajustar este comportamento do G64.

No caso específico do colega, será necessário ver o que acontece porque os efeitos em G64 estão absolutamente exagerados - provavelmente ele deve ter uma instalação defeituosa porque mesmo depois de ter alterado o ajuste para G61 ele reclama que as curvas são muito lentas - talvez ele esteja com acelerações muito baixas e o planejador não consegue fazer seu trabalho direito.

Offline Cássio Alvarenga

  • Moderador
  • CNCMASTER
  • ******
  • Posts: 3429
  • Sexo: Masculino
    • www.vatech.ind.br
  • Cidade - UF: Belo Horizonte - MG
  • Profissão: Empresario / Engenheiro Mecânico
Re:Problemas no Percurso REalizado
« Resposta #8 Online: 15 de Abril de 2012, 12:48 »
Entendi, valeu!!  ;D

 

Offline MARCELO PALMA

  • Teco de eletronica
  • Novato
  • *
  • Posts: 21
  • Sexo: Masculino
  • Cidade - UF: São Lourenço-MG
Re:Problemas no Percurso REalizado
« Resposta #9 Online: 15 de Abril de 2012, 16:40 »
Tive problema assim , aumentei a aceleração e ficou legal , mais foi bom aprender essa dico do mestre Gilli

Offline Neto g

  • Fuso
  • **
  • Posts: 112
  • Sexo: Masculino
  • Há uma maneira de faze-lo melhor: encontre-a.
  • Cidade - UF: Guarujá - São Paulo
  • Nome:: Nacim Gaze
Re:Problemas no Percurso REalizado
« Resposta #10 Online: 17 de Abril de 2012, 11:35 »
Prezados Amigos Foristas,

Após a Digitação do código G61, percebi que a cada curva exitstente nas peças que estou fazendo, a ferramenta segue o percurso dando alguns "solavancos", se é assim que podemos dizer pelo motor de passo, por isso preciso de uma ajuda dos colegas para ter uma noção dos diagnósticos existentes, por isso, vou colocar todas as infosmarções possíveis da CNC e da config do Mach3

Segue um vídeo da CNC Usinando: http://youtu.be/YT6hQHxUe7w
Nessa usinagem foi utilizado uma velocidade de tanto corte como tranferência, de 3000mm/min e aceleração de 90mm/seg

Motores de passo de 32KGF em Ligação Bipolar, mas estou usando 22KGF usando Ligação Unipolar com os drivers Smile
Utilizo CAbo PP Blindado no Spindle
O Meu computador é dedicado à CNC

Segue algumas fotos da minha config do Mach3

Abraços Nacim

Offline F.Gilii

  • Administrador
  • CNCMASTER
  • *******
  • Posts: 13795
  • Sexo: Masculino
  • Consultoria, Automação e Construção de Máquinas
  • Cidade - UF: Atibaia - SP
  • Nome:: Fabio Gilii
  • Profissão: Tec. Mecanica de Precisão
Re:Problemas no Percurso REalizado
« Resposta #11 Online: 17 de Abril de 2012, 12:05 »
Nacim,

Posso estar errado, mas na primeira imagem aparece um arquivo gerado e tive a impressão que está usando um pós processador que gera curvas sem interpolação - gera como se fossem diversas pequenas retas.
Sugiro trocar de póa processador - as curvas serão feitas de forma mais suave e contínua.

Na segunda imagem, me parece que a aceleração está muito comportada para a velocidade usada (3000 mm/min) - experimente colora 300 na aceleração.

Na terceira imagem:
- Look Ahead - está com 20, coloque 200
- CV Control (do lado direito, em baixo)
Está com 180 unidades - coloque 50 e experimente
- desligue o comando "G100 Adaptive Nurbs"
- Ligue o comando "Stop CV on Angles >" e coloque 75 na janela

Offline Neto g

  • Fuso
  • **
  • Posts: 112
  • Sexo: Masculino
  • Há uma maneira de faze-lo melhor: encontre-a.
  • Cidade - UF: Guarujá - São Paulo
  • Nome:: Nacim Gaze
Re:Problemas no Percurso REalizado
« Resposta #12 Online: 17 de Abril de 2012, 13:00 »
Prezado Gilii,

Antes de mais nada, obrigado pela rápida resposta, e pelas indicações, não é a toa que você é o nosso mestre!  :)

Vou fazer as modificações, e, daqui a pouco volto aqui pra postar o resultado.

Um Abraço Nacim

Offline Neto g

  • Fuso
  • **
  • Posts: 112
  • Sexo: Masculino
  • Há uma maneira de faze-lo melhor: encontre-a.
  • Cidade - UF: Guarujá - São Paulo
  • Nome:: Nacim Gaze
Re:Problemas no Percurso REalizado
« Resposta #13 Online: 17 de Abril de 2012, 21:11 »
Fábio Boa Noite

Passei a Tarde Realizando aquelas alterações, e agora, em velocidade constante (G64) o movimento melhorou bastante, mas queria era que tivesse um movimento suave, com a interpolação e utilizando o G61...os soquinhos ainda existem mas acredito que com o uso da interpolação isso deve sumir. Por isso agradeço os toques que vc me deu.

Agora uma coisa que vale a pena mencionar é que vc havia falado do pós processador. O que acontece é que quando faço Cortes 2D (perfilagens) no Visual Mill, depois de gerado o código, eu uso um comando chamado "Linearize Toolpath" que retira as interpolações, e transforma td em coordenada. O Motivo de fazer isso, é que a primeira vez que fiz uma perfilagem no VM e coloquei no Mach3 para rodar, deu uma tela de erro, dizendo a seguinte frase no campo MSG do Mach3:"Radius to end of the arc differs from radius to start Line XX" Segue um Printscreen em anexo. Por isso acabei adotando esse procedimento um tempo atrás, que agora estou vendo que está gerando esse problema.Alguem sabe o motivo dessa Mensagem?

Um Abraço Nacim

Offline Neto g

  • Fuso
  • **
  • Posts: 112
  • Sexo: Masculino
  • Há uma maneira de faze-lo melhor: encontre-a.
  • Cidade - UF: Guarujá - São Paulo
  • Nome:: Nacim Gaze
Re:Problemas no Percurso REalizado
« Resposta #14 Online: 18 de Abril de 2012, 08:32 »
Acho que descobri o Erro da Msg no Mach3....li em alguns fóruns americanos usuários que tiveram o mesmo problema...eles trocaram o IJ Mode de Absoluto para Incremental em General Config e deu certo...daqui a pouco vou testar e posto aqui o resultado.

Abraço Nacim